Forum Pplware

Versão Completa: Elastix com VOIP Telepac
Está de momento a ver uma versão reduzida do nosso conteúdo. Ver versão completa com o formato adequado.
Boa tarde, embora já utilize VOIP à bastante tempo, sempre utilizei as soluções mais básicas (Router da Sapo e Linksys PAP2).

Aproveitei uma máquina mais velhinha para fazer uns testes com o elastix, mas como os conhecimentos são reduzidos apenas consegui criar as extenções.

Estou a utilizar o X-Lite e consigo fazer chamadas entre extenções, mas não consigo configurar o elastix de forma a que me seja possivel realizar chamadas para o exterior.

Pedia então a vossa ajuda para conseguir configurar uma conta VOIP da Telepac no elastix 2.2.

Muito obrigado pela atenção.
Aqui fica o meu pequeno manual para configurar o Elastix de forma a efectuar e receber chamadas utilizando uma conta VOIP Telepac/Sapo.

1- Abrir a o interface de configuração do elastix no seu browser:

[Imagem: 11152246_1.jpg]

2- Seleccionar "PBX" -> "Trunks" -> "Add SIP Trunk"

[Imagem: 11152248_2.jpg]

3- Preencher os dados da seguinte forma:

[Imagem: 11152249_3.jpg]
  • General Settings:
  • - Trunk Name: Nome que pretenderem para identificação do SIP
  • - Outbound Caller ID: preencher com os vossos dados ex. "Picomática"(substituir os "x" pelo vosso número)
  • Outgoing Settings:
  • - Trunk Name: Novamente o nome que pretenderem para identificação
  • - PEER Details: (substituir os "x" pelo vosso número e inserir a vossa SENHA)

    username=+35130xxxxxxx
    type=friend
    secret=SENHA
    registername=+35130xxxxxxx
    qualify=yes
    port=5070
    insecure=very
    host=proxy.voip.telepac.pt
    fromuser=+35130xxxxxxx
    fromdomain=voip.telepac.pt
    dtmfmode=rfc2833
    disallow=all
    context=from-trunk
    canreinvite=yes
    call-limit=1
    authname=+35130xxxxxxx
    allow=ulaw&alaw
    #nat=yes
  • Registration
  • - Registration String: (substituir os "x" pelo vosso número e inserir a vossa SENHA)

    +35130xxxxxxx@voip.telepac.pt:SENHA:+35130xxxxxxx@proxy.voip.telepac.pt:5070/+35130xxxxxxx

4- Sempre dentro do menu PBX seleccionar a opção Outbound Routes:

[Imagem: 11152252_4.jpg]
  • Route Settings
  • - Route Name: Nome que pretenderem para identificação
  • Additional Settings
  • - Dial Patterns that will use this Route: Preencher o campo "match pattern" com "X."
  • - Trunk Sequence for Matched Routes: seleccionar o Trunk criado no ponto 3

5- Sempre dentro do menu PBX seleccionar a opção Extensions e Adicionar as extenções pretendidas (no meu caso utilizo o SoftPhone X-Lite)

[Imagem: 11152253_5.jpg]

6- Sempre dentro do menu PBX seleccionar a opção Inbound Routes:

[Imagem: 11152255_6.jpg]
  • Edit Incoming Route
  • - Description: Nome que pretenderem para identificação
  • Set Destination
  • - Primeira opção seleccionar "Extensions" -> Segunda opção seleccionar a extensão que pretendem que toque quando recebem uma chamada.

Para utilizadores Sapo, basta alterarem de "telepac" para "sapo" nas configurações.

Esta é apenas uma configuração básica, mas está funcional, agora é uma questão de personalizar o funcionamento do Elastix de acordo com as vossas necessidades.

Sem mais assunto, com os melhores cumprimentos,

Paulo Brinca - Picomática
Boas,

Apliquei estas configurações mas não consigo fazer chamadas.

Recebo OK, mas não consigo fazer, dá a mensagem de "all circuis are busy now".

Alguma ideia?

Obg.
PM
Tinha de vir aqui agradecer por este fantástico post!!

Obrigado!
eu também quero agradecer não é que precise neste momento mas pode dar jeito obrigado
(09-04-2012 16:16)pedro.moreno@layer3.pt Escreveu: [ -> ]Boas,

Apliquei estas configurações mas não consigo fazer chamadas.

Recebo OK, mas não consigo fazer, dá a mensagem de "all circuis are busy now".

Alguma ideia?

Obg.
PM

Boas pessoal, estou exactamente com o mesmo problema e já dei voltas e mais voltas e não consigo por isto a fazer chamadas, porque receber ele recebe. Logo o VoIP Provider está bem configurado, agora o 'Outbound' é que me está a matar a cabeça. Será que alguém consegue dar uma ajudinha.

Obrigado.
Viva,

Ainda nao tive necessidade de configurar um servidor voip mas do que tenho lido, esse erro geralmente está ligado a algum erro na configuracao.

Mais especificamente, sugiro que voltes a verificar username e password.
Mas se recebo chamadas é porque o SIP está bem configurado.

Tanto é que se fizer no Asterisk-Cli: "sip show registry" ele devolve-me:

"Host dnsmgr Username Refresh State Reg.Time
proxy.voip.sapo.pt:5070 N +3513020XXXXX 105 Registered Tue, 10 Jul 2012 16:11:29
1 SIP registrations."

(ocultei o numero) daí não perceber porque não deixa fazer chamadas... :/
A configuracao para envio é diferente da configuracao para recepcao, daí sugerir para reveres os passos.

É semelhante ao email..se a configuracao estiver incorrecta, podes receber mas nao podes enviar (ou vice-versa).


De qualquer forma, deves ter aí algo para troubleshooting, talvez um traceroute (para veres o encaminhamento).
Alguém pode dar mais alguma ajuda, é que estou com o mesmo problema e preciso disto pronta para a semana que vêm??
URL's de Referência