Forum Pplware

Versão Completa: vpn pptp
Está de momento a ver uma versão reduzida do nosso conteúdo. Ver versão completa com o formato adequado.
Boas pessoal

Necessitava de uma ajuda vossa que eu já ando aqui á cabeçada á uns dias e nada.



Então eu tenho um servidor pptp num tp-link e acontece uma coisa que ainda não consegui dar a volta.

então é o seguinte eu se me ligar num pc ao servidor tudo 5 * tenho acesso a tudo na rede até aqui tudo bem.



Mas quando tento ligar com um outro router ao meu servidor ele conecta mas acesso á rede é que nem vela eu no servidor consigo ver que conecta e está tudo bem mas pingar ip's da rede é que não faz.

se entrar por telnet e pingar o ip do servidor tudo ok, mas se tentar pingar um equipamento da rede (raspberry) nada.


O que eu pretendia é ter numa ponta o router servidor vpn (pptp) e na outra ponta um outro router com cliente(pptp).
Eu os routeres já tenho e conectam um com o outro. mas se me ligar ao router cliente não consigo pingar nada da vpn se me ligar por telnet so o servidor é que consigo pingar tbm.

Alguem tem uma ideia como por isto a funcionar?

Cumprimentos
Viva,

Não sei se ainda vou a tempo.

O teu problema aparenta ser de rotas no router Cliente/Servidor.

Quando um PC liga-se ao servidor usando o PPP, ele assume o IP do servidor como gateway de todas as redes que não conhece. Por este motivo tu consegues ter acesso à rede através de um PC.

Quando tens uma ligação PPTP servidor/cliente com routers. O router apenas conhece as redes a que está directamente ligado. E por isso consegues do cliente pingar o servidor mas não consegue pingar máquinas noutra rede ligado ao servidor servidor.

Resumindo:
No servidor, vais ter de configurar rotas estáticas apontar para o cliente, para as redes locais desse router.
No cliente, vais ter de configurar rotas estáticas apontar para o servidor, para as redes locais desse router.

Cumprimentos,
URL's de Referência