Forum Pplware

Versão Completa: O firewall do windows bloqueia-me acesso ao telemóvel
Está de momento a ver uma versão reduzida do nosso conteúdo. Ver versão completa com o formato adequado.
Normalmente ligo o meu Samsung Omnia II através de USB ao meu computador. Normalmente aparece uma drive que, ao clicar, dá origem a duas mais: uma para a memória interna do telemóvel, outra ao cartão de memória embutido. Além disso, o Windows Mobile Device Center detecta-o e faz as sincronizações.

Devido a um problema, cliquei no botão de reposição das definições do windows firewall. Desde então que quando ligo o telemóvel ao computador por USB, o firewall bloqueia-o.

Quando desligo o firewall, detecta-o: aparece a drive e o windows mobile center encontra o telemóvel. Se activo o firewall, tudo isso desaparece.

Tenho o Vista 64bits, estou a usar o firewall do próprio windows. Nas definições, posso adicionar excepções a programas... Mas a detecção USB do telemóvel não é nenhum programa. Por isso não sei o que fazer!

Alguém pode ajudar-me, sff?
Verifica se nas excepções da firewall do Windows está marcado o Windows Mobile Device Center.

Para mais detalhes vê Firewall conflicts no seguinte link,

Windows Mobile Device Center Troubleshooting
Não aparece esse item, mas fui ao directório no \Windows\WindowsMobile e autorizei todos os programas lá. Nada. Sad

Já li o artigo e não encontri a solução. Sad
Mas ao adicionares os ficheiros devia funcionar, não te esqueceste de nenhum ficheiro?

Citar:C:/Windows/WindowsMobile/wmdc.exe
C:/Windows/WindowsMobile/wmdHost.exe
C:/Windows/WindowsMobile/wmdsyncman.dll
Não tinha esse dll, mas já experimentei e não dá.

Mas desconfio que o problema não seja do windows mobile device center ser bloqueado pela firewall, porque se fosse, seria bloqueado mas deveria aparecer uma drive no explorer, tal como aparece quando colocamos um cartão ou uma pen drive...

Eu ouço o barulho típico de quando inserimos algo na porta USB. Só que depois não aparece nada. Se desligar a firewall, aparece no explorer e o WMDC faz a sincronização.

Já não sei o que fazer. Até experimentei reinstalar drivers e nada. Sad
Abriste as portas que referem no artigo?

Citar:To resolve conflicts with firewalls, you have to add WMDC to the list of trusted applications. WMDC has the following components:

C:/Windows/WindowsMobile/wmdc.exe
C:/Windows/WindowsMobile/wmdHost.exe
C:/Windows/WindowsMobile/wmdsyncman.dll
These components have to be allowed to communicate in your firewall settings, allowing them to have full server priviliges. As for the used IP-adresses, WMDC uses 169.254.2.1 for your PC and 169.254.2.2 for your Windows Mobile 5.0 device. For these ip-adresses, the following ports have to be open:

Inbound TCP:
990
999
5678
5721
26675
Outbound UDP:
5679
Outbound TCP:
990

The application using these ports is C:/Windows/WindowsMobile/wmdHost.exe.

Encontrei isto num forum do Windows Seven, não sei se ajuda

Citar:I was having some issues getting the Windows Mobile Device Center to connect to my Mobile Device. I checked around the forum and could not find much on the topic. In order to get this to work you need to do the following:

Control Panel
Windows Firewall
Advanced Settings
Inbound Rules
Create a new "Inbound Rule" and name it Windows Mobile Device Center
Click on the "Protocols and Ports" tab
Protocol Type - TCP
Local Port - Specific Ports, 990, 999, 5678, 5679, 5721, 26675
Remote port - All Ports
LEAVE ALL OTHER OPTIONS AT THEIR DEFAULT VALUE
Click Apply
Click OK

Disconnect and Reconnect Mobile Device
Create Partnership etc....
(14-05-2010 09:53)nioxys Escreveu: [ -> ]Encontrei isto num forum do Windows Seven, não sei se ajuda

Citar:I was having some issues getting the Windows Mobile Device Center to connect to my Mobile Device. I checked around the forum and could not find much on the topic. In order to get this to work you need to do the following:

Control Panel
Windows Firewall
Advanced Settings
Inbound Rules
Create a new "Inbound Rule" and name it Windows Mobile Device Center
Click on the "Protocols and Ports" tab
Protocol Type - TCP
Local Port - Specific Ports, 990, 999, 5678, 5679, 5721, 26675
Remote port - All Ports
LEAVE ALL OTHER OPTIONS AT THEIR DEFAULT VALUE
Click Apply
Click OK

Disconnect and Reconnect Mobile Device
Create Partnership etc....

Muitíssimo obrigado! Problema resolvido. Smile
De nada Smile

Sempre às ordens Wink
URL's de Referência