Forum Pplware
Problemas Ubuntu 9.04 - Versão de Impressão

+- Forum Pplware (http://forum.pplware.com)
+-- Fórum: Software (/forumdisplay.php?fid=4)
+--- Fórum: GNU/Linux (/forumdisplay.php?fid=7)
+--- Tópico: Problemas Ubuntu 9.04 (/showthread.php?tid=2614)

Páginas: 1 2 3


RE: Problemas Ubuntu 9.04 - tiago_pnf - 17-06-2009 11:16

Viva BitandByte

O chip de áudio que aparece é: Nvidia MCP7A HDMI.

O portatil é o acer aspire 5737z

Cumprimentos


RE: Problemas Ubuntu 9.04 - BitandByte - 17-06-2009 13:29

Viva Tiago,
OK experimente então correr:

Código:
head -n 1 /proc/asound/card0/codec*

E escreva o que aparece no terminal, por favor.

Cumprimentos!


RE: Problemas Ubuntu 9.04 - tiago_pnf - 17-06-2009 18:24

Aparece isto:

==> /proc/asound/card0/codec#0 <==
Codec: Realtek ALC888

==> /proc/asound/card0/codec#3 <==
Codec: Nvidia MCP7A HDMI


RE: Problemas Ubuntu 9.04 - JCarvalho - 17-06-2009 21:26

Boas.

Esta é uma ideia meio parva, mas pode ser que ajude. No controlo de volume, no separador interruptores tens o visto em headphone?

Um abraço


RE: Problemas Ubuntu 9.04 - BitandByte - 17-06-2009 22:10

Caro Tiago, experimente isto:

Código:
sudo nano /etc/modprobe.d/alsa-base

adicione a linha:

options snd-hda-intel model=laptop

onde observar que estão as outras opções. Guarde o ficheiro e saia do terminal.
Faça um reset ao X server (ctrl+Alt+backspace) e veja se está a funcionar!

Boa sorte!
Cumprimentos!


RE: Problemas Ubuntu 9.04 - tiago_pnf - 17-06-2009 22:48

Desculpe, mas não tenho a certeza se fiz correctamente como pretendia.

Fiz como mostra esta imagem:

[Imagem: capturaecraz.png]

Fiz correctamente? Se fiz correctamente, o problema infelizmente manteve-se.


RE: Problemas Ubuntu 9.04 - BitandByte - 17-06-2009 23:04

Viva!

Esqueça isso, o ficheiro alvo devia ter algo nele escrito e não um ficheiro vazio!

Entretanto lembrei-me de outra coisa...

Faça antes assim:

su
(e introduza a pass para root)

lsof /dev/snd/* (isto serve para ver se estão a correr processos a utilizar o módulo de som)

Se sim, mate os processos:

kill <PID> (onde em <PID> coloca o numero de identificação do processo que está a utilizar o módulo, demonstrado pelo comando anterior)

De seguida:
rmmod snd-hda-intel (este comando serve para remover o módulo de som)

Está tudo a postos para recarregar o módulo de som da seguinte forma:

modprobe snd-hda-intel model=O_SEU_MODELO

Onde em O_SEU_MODELO coloca, no seu caso, acer, portanto:

modprobe snd-hda-intel model=acer

Agora verifique se o problema continua! Pode experimentar mais modelos, que para o seu chip são:

Código:
ALC883/888
        3stack-dig   3-jack with SPDIF I/O
        6stack-dig   6-jack digital with SPDIF I/O
        3stack-6ch    3-jack 6-channel
        3stack-6ch-dig 3-jack 6-channel with SPDIF I/O
        6stack-dig-demo  6-jack digital for Intel demo board
        acer      Acer laptops (Travelmate 3012WTMi, Aspire 5600, etc)
        medion   Medion Laptops
        targa-dig   Targa/MSI
        targa-2ch-dig   Targs/MSI with 2-channel
        laptop-eapd   3-jack with SPDIF I/O and EAPD (Clevo M540JE, M550JE)
        auto      auto-config reading BIOS (default)

Como vê, o acer está lá! Pode também experimentar o auto. O processo é sempre este, depois de experimentar o primeiro, é utilizar o comando para remover o módulo e carregar novamente com novo modelo...

Uma coisa é certa, SE este processo não resultar, pelo menos terá no seu programa de controlo de volume de som (que em ubuntu não sei qual é, em kubunto é o kmix) terá um canal chamado de surround. Este comanda o volume dos altifalantes do seu portátil! Ou seja, cada vez que desejar ouvir música apenas pelos headphones, baixa este canal e continua com som nos headphones. É uma solução má, bem sei, mas não estou a ver mais nada que se possa fazer!

Qualquer dúvida comunique,
Cumprimentos! e Boa sorte Smile


RE: Problemas Ubuntu 9.04 - tiago_pnf - 18-06-2009 00:06

Bem caro BitandByte, o meu muito obrigado! Smile

Testei todos os modelos, nenhum deles dava, mas quando meti o auto, funcionou perfeitamente. É que nem o som das colunas podia baixar e meter só som nos phones, pois alem de as colunas continuarem a tocar, nos phones não saía qualquer som. Agora sim está tudo na normalidade.

Cumprimentos e obrigado também ao resto dos utilizadores que responderam ao tópico.


RE: Problemas Ubuntu 9.04 - BitandByte - 18-06-2009 00:42

Viva Tiago!

Folgo em saber que o seu problema foi resolvido =)

Não tem de quê!

Cumprimentos!

EDIT: Esqueci-me de dizer que tem que tornar as modificações definitivas!

Para tal:

1) su
2) echo "options snd-hda-intel model=auto" >> /etc/modprobe.d/alsa-base.conf
aqui está a minha dúvida, não sei se o ficheiro que contém as opções está em /etc/modprobe.d/ e se se chama alsa-base.conf. Para tal terá que averiguar, seguir a sua intuição! Aqui é assim mas não sei se será o mesmo para ubuntu.

O meu ficheiro alsa-base.conf em /etc/modprobe.d/ é:
Código:
# autoloader aliases                            
install sound-slot-0 /sbin/modprobe snd-card-0  
install sound-slot-1 /sbin/modprobe snd-card-1  
install sound-slot-2 /sbin/modprobe snd-card-2  
install sound-slot-3 /sbin/modprobe snd-card-3  
install sound-slot-4 /sbin/modprobe snd-card-4  
install sound-slot-5 /sbin/modprobe snd-card-5  
install sound-slot-6 /sbin/modprobe snd-card-6  
install sound-slot-7 /sbin/modprobe snd-card-7  

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }                                                                      
#                                                                              
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from beeing loaded as first soundcard
options snd-pcsp index=-2

Portanto deverá se parecer com algo do género! o comando em 2) adiciona no final da linha deste ficheiro: options snd-hda-intel model=auto Smile

de seguida:
3) update-modules

e pronto, reiniciar a máquina e evidenciar se continua tudo bem Smile

Cumprimentos!


RE: Problemas Ubuntu 9.04 - tiago_pnf - 18-06-2009 16:21

Viva,

Pois vinha agora ao tópico, perguntar-lhe como meto as definições definitivas.

Em ubuntu é exactamente o mesmo ficheiro, já confirmei e realmente adiciona no final do ficheiro: options snd-hda-intel model=auto, porem não consigo executor o comando: update-modules, pois aparece: comando não encontrado e por isso sempre que reinicio volta a não dar os headphones, como poderei correr o comando update-modules?

Ja agora o meu ficheiro etc/modprobe.d/alsa-base.conf

Código:
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from beeing loaded as first soundcard
options snd-pcsp index=-2
options snd-hda-intel model=auto
options snd-hda-intel model=auto

Como pode ver aparece duas vezes no fim, options snd-hda-intel model=auto, porque provavelmente fiz mal, mas quando reiniciei e os phones não davam, voltei a fazer tudo de novo e executei novamente o comando fazendo aparecer agora duas vezes no ficheiro, provavelmente não é relevante estar lá duas vezes, caso seja como retiro?